// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:src=)(".*?")"#).unwrap();
let string = "Russia's National Settlement Depository discusses why it believes the biggest blockchain opportunities have yet to be uncovered.<img alt=\"\" height=\"1\" src=\"http://feeds.feedburner.com/~r/CoinDesk/~4/rvoQUj-KDaw\" width=\"1\" />|One of the co-founder of digital currency startup Stellar announced their resignation today.<img alt=\"\" height=\"1\" src=\"http://feeds.feedburner.com/~r/CoinDesk/~4/xRzN7syt-v0\" width=\"1\" />|The editorial board for Bloomberg News has called for a permissive regulatory environment for blockchain development.<img alt=\"\" height=\"1\" src=\"http://feeds.feedburner.com/~r/CoinDesk/~4/ooQYB2iDxP8\" width=\"1\" />";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}