re = /(BEGIN @\d+)\b(?s:.*?)(ACTION_READLN.*)/
str = 'BEGIN @1011 Text
Text
ACTION_READLN ~corantimer~
Text
END
BEGIN @1012
asdasd
ACTION_READLN ~corantimer~
END
BEGIN @1013
asd
END'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end