// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(BEGIN @\d+)\b(?s:.*?)(ACTION_READLN.*)").unwrap();
let string = "BEGIN @1011 Text
Text
ACTION_READLN ~corantimer~
Text
END
BEGIN @1012
asdasd
ACTION_READLN ~corantimer~
END
BEGIN @1013
asd
END";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}