#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!doc$).)*$"
Local $sString = "group/ps/doc" & @CRLF & _
"group/doc" & @CRLF & _
"doc" & @CRLF & _
"groups/release" & @CRLF & _
"dev/releas" & @CRLF & _
"docker/release" & @CRLF & _
"group/cloud-doc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")