use strict;
my $str = 'upload/resize_cache/iblock/daa/455_475_075511db9cefbc414a902a46f1b8fae16/5_wIdyXJL7A.jpg';
my $regex = qr/(^.+\/)([^\.]+)\.([^\.]+)/p;
my $subst = '$1$2XXXXXXXXXXXXL.$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";