import Foundation
let pattern = #"<div class="podEventRow[^>]+>(\s*<div class="[^>]+>\s*(<span[^>]+>|</span>|</?em>|[\s0-9/,.+-]+)+[^<]*</div>\s*)+</div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
<div class="podEventRow singleRow" data-plbtid="50139">
<div class="wideLeftColumn centered"><em>4.0, 4.5</em></div>
<div class="priceColumn third " data-nav="pt=N#o=27/5#f=54849113#fp=962365111#so=0#c=1#ln=4.25" data-displayorder="27">6.400</div>
<div class="priceColumn third " data-nav="pt=N#o=23/200#f=54849113#fp=962365112#so=0#c=1#ln=4.25" data-displayorder="28">1.115</div>
</div>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)