#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\"url\":\ \")(.*)(\")"
Local $sString = ""id": 1," & @CRLF & _
""owner_id": 1," & @CRLF & _
""artist": "foo"," & @CRLF & _
""title": "bar"," & @CRLF & _
""duration": 1," & @CRLF & _
""date": 1," & @CRLF & _
""url": "http://vk... .flac"," & @CRLF & _
""lyrics_id": 1," & @CRLF & _
""genre_id": 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")