# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s?(?:RuleSet|Data):\[[^]]*](?:,?\s|$)//gmix;t' <<< "RuleSet:[text], Data:[{text}{text}...] RuleSet:[text], Data:[{text},{text},....] SomeText RuleSet:[{text}...], Data:[{text}...]"