const regex = new RegExp('(<a href=".*(/media/video/\\d+/)"*[^>]*>([^<]+)</a>)', '')
const str = `<div class="videoTitle"><a href="/media/video/1234/" title='ddd "da"'>
bla lba
</a></div>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);