import re
regex = re.compile(r"(<a href=\".*(/media/video/\d+/)\"*[^>]*>([^<]+)</a>)")
test_str = ("<div class=\"videoTitle\"><a href=\"/media/video/1234/\" title='ddd \"da\"'>\n"
"bla lba\n"
"</a></div>")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)