#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "input.*(?<=name=['|"])([\w]+)"
Local $sString = "<form method="post" action="">" & @CRLF & _
" <input type="hidden" name="produto1" value="teste1">" & @CRLF & _
" <input type="hidden" name='produto2' value="teste2">" & @CRLF & _
" <input name="produto3" type="hidden" value="teste3">" & @CRLF & _
" <input type="hidden" name='produto4' value="teste4">" & @CRLF & _
" <input type="hidden" name="produto5" value="teste5">" & @CRLF & _
" " & @CRLF & _
"<input type="submit" value="enviar">" & @CRLF & _
"</form>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")