import Foundation
let pattern = #"input.*(?<=name=['|"])([\w]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<form method="post" action="">
<input type="hidden" name="produto1" value="teste1">
<input type="hidden" name='produto2' value="teste2">
<input name="produto3" type="hidden" value="teste3">
<input type="hidden" name='produto4' value="teste4">
<input type="hidden" name="produto5" value="teste5">
<input type="submit" value="enviar">
</form>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)