package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)content=\\\"(?P<content>.*)\\\".*property=\\\"(?P<prop>.*)\\\"\/>`)
var str = `<meta content=\"Allrecipes\" property=\"og:site_name\"/>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}