const regex = new RegExp('content=\\\\\\"(?P<content>.*)\\\\\\".*property=\\\\\\"(?P<prop>.*)\\\\\\"\\/>', 'gm')
const str = `<meta content=\\"Allrecipes\\" property=\\"og:site_name\\"/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}