$re = '/content=\\\\\"(?P<content>.*)\\\\\".*property=\\\\\"(?P<prop>.*)\\\\\"\/>/m';
$str = '<meta content=\\"Allrecipes\\" property=\\"og:site_name\\"/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);