use strict;
my $str = 'कपिल शर्मा % * _';
my $regex = qr/[^\p{M}\w]+/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";