#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[A-Za-z0-9]{8}).*EXEC.*PGM=([A-Za-z0-9]*)(?:,PARM='([A-Za-z0-9,()=]*)')?(?:,COND=\(([A-Za-z0-9,]*)\))?"
Local $sString = "STEP0010 EXEC PGM=SORT,PARM='SIZE(MAX),DYNALLOC=(SYSDA,15)',COND=(0,NE)" & @CRLF & _
"STEPCTLG EXEC PGM=IEFBR14,COND=(4,LT)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")