using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[A-Za-z0-9]{8}).*EXEC.*PGM=([A-Za-z0-9]*)(?:,PARM='([A-Za-z0-9,()=]*)')?(?:,COND=\(([A-Za-z0-9,]*)\))?";
string input = @"STEP0010 EXEC PGM=SORT,PARM='SIZE(MAX),DYNALLOC=(SYSDA,15)',COND=(0,NE)
STEPCTLG EXEC PGM=IEFBR14,COND=(4,LT)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}