package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\(.+\).*(*SKIP)(*F)|<\?=(.+?)\?>`)
var str = `$content = 'Hello world, ( this ) is a string with { curly brackets } and this is for testing'
foo(?!\()
<?= number_format($taghsimatCount) ?>
ffh<>
<?= $djhsfgjs ?>
<?= djhsfgjs($fsdjfk) ?>
<?= $fdgdfgfd?>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}