$re = '/\\\\n\s*(?=\b(?:\d+|A)(?:\.\d+)*\.\B\s*(?:"\s?|“)?\w+)/m';
$str = '\\nA.8. "text
\\n 8.4.2.4.1.2. text
\\n9.1. 12 digit and text
\\n9. text
\\n10.0.1.1. " text
\\n9 text
\\n0.1 Hz
\\n 100. text
\\n 100.5.1. text
\\nA.500 text
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);