const regex = /^\h*(?=(?:\d+|A)(?:\.\d+)*\.(?!\S))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\h*(?=(?:\\d+|A)(?:\\.\\d+)*\\.(?!\\S))', 'gm')
const str = `A.8. "text
8.4.2.4.1.2. text
9.1. 12 digit and text
9. text
10.0.1.1. " text
9 text
0.1 Hz
100. text
100.5.1. text
A.500 text
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}