#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm){{Template1(?:[^{}]*?(?:{{[^}]+?}}))+(?:}+)*"
Local $sString = "..." & @CRLF & _
"abas asdn asf asfs af{{Template1|a = Name surname|b = jhsdf sdf|c = {{Template2}}|d = |e = [[f]] and [[g]]|h = asd asdasfgasgasg asgas jygh trdx dftf xcth|i = 73|j = {{Template2|abc|123}}|j = {{Template3|aa=kkk|bb={{Template4|cc=uu}}}}}}asd wetd gdsgwew g{{OtherTemplate|sdf 213}}..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")