package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm){{Template1(?:[^{}]*?(?:{{[^}]+?}}))+(?:}+)*`)
var str = `...
abas asdn asf asfs af{{Template1|a = Name surname|b = jhsdf sdf|c = {{Template2}}|d = |e = [[f]] and [[g]]|h = asd asdasfgasgasg asgas jygh trdx dftf xcth|i = 73|j = {{Template2|abc|123}}|j = {{Template3|aa=kkk|bb={{Template4|cc=uu}}}}}}asd wetd gdsgwew g{{OtherTemplate|sdf 213}}...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}