import Foundation
let pattern = #"{{Template1(?:[^{}]*?(?:{{[^}]+?}}))+(?:}+)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
...
abas asdn asf asfs af{{Template1|a = Name surname|b = jhsdf sdf|c = {{Template2}}|d = |e = [[f]] and [[g]]|h = asd asdasfgasgasg asgas jygh trdx dftf xcth|i = 73|j = {{Template2|abc|123}}|j = {{Template3|aa=kkk|bb={{Template4|cc=uu}}}}}}asd wetd gdsgwew g{{OtherTemplate|sdf 213}}...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)