$re = '/href=["\']https?:\/\/(?<hostname>[^\/]+)[^>]+>(?:https?:\/\/)?\k\'hostname\'/i';
$str = '<A HREF="http://phishers.org/we_want_your_money.htm">http://someLegitimateSite.com/somewhere </A>
<a href="https://example.com/subfolder">example.com</a>
<a href="http://somebadsite.com">https://somegoodsite.com</a>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);