using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=[""']https?:\/\/(?<hostname>[^\/""]+)[^>]+>(?:https?:\/\/)?(?!.*\k'hostname')";
string input = @"<A HREF=""http://phishers.org/we_want_your_money.htm"">http://someLegitimateSite.com/somewhere </A>
<a href=""https://example.com/subfolder"">example.com</a>
<a href=""http://somebadsite.com"">https://somegoodsite.com</a>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}