#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""(.*?)\(.*?:(.*)"
Local $sString = ""text1(text1)":http://www.example.com/mypage"
Local $sSubst = "<a href="\2">\1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)