using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(.*?)\(.*?:(.*)";
string substitution = @"<a href=""\2"">\1</a>";
string input = @"""text1(text1)"":http://www.example.com/mypage";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}