// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(.*?)\(.*?:(.*)"#).unwrap();
let string = "\"text1(text1)\":http://www.example.com/mypage";
let substitution = "<a href=\"\\2\">\\1</a>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}