using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[~([^\]]+)\]";
string input = @"Completely engineer client-based strategic [~theme 123] areas before cross [~media] technology [this is fine] ok?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}