use strict;
my $str = 'abcj hsd723=198 2912
abcjhsd7231982912 13123
1212
';
my $regex = qr/^((?!=).)*$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";