const regex = /(?(DEFINE)
(?P<elt>
[^,()]*+
(?:
\( (?&elt) (?: , (?&elt) )* \)
[^,()]*
)*+
)
)
FOO\( \s*
(?P<elt1> (?&elt) )
, \s*
(?P<elt2> (?&elt) )
, \s*
(?P<elt3> (?&elt) )
\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)
(?P<elt>
[^,()]*+
(?:
\\( (?&elt) (?: , (?&elt) )* \\)
[^,()]*
)*+
)
)
FOO\\( \\s*
(?P<elt1> (?&elt) )
, \\s*
(?P<elt2> (?&elt) )
, \\s*
(?P<elt3> (?&elt) )
\\)', 'g')
const str = `FOO( something, BOO(tmp, temp), something else)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}