// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?(DEFINE)
(?P<elt>
[^,()]*+
(?:
\( (?&elt) (?: , (?&elt) )* \)
[^,()]*
)*+
)
)
FOO\( \s*
(?P<elt1> (?&elt) )
, \s*
(?P<elt2> (?&elt) )
, \s*
(?P<elt3> (?&elt) )
\)").unwrap();
let string = "FOO( something, BOO(tmp, temp), something else)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}