using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?im)^[a-z\dâ„¢][a-z\d\sâ„¢]{1,24}(?<!\s)$";
string input = @"AdriaN
$tackoverFlow
StackoverF
StackoverFl0w
â „¢ Stack Over Flow â„¢
StækOverFlow";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}