const regex = /(?im)^[a-z\dâ„¢][a-z\d\sâ„¢]{1,24}(?<!\s)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?im)^[a-z\\dâ„¢][a-z\\d\\sâ„¢]{1,24}(?<!\\s)$', 'g')
const str = `AdriaN
\$tackoverFlow
StackoverF
StackoverFl0w
â„¢ Stack Over Flow â„¢
StækOverFlow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}