# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<div\s\w{5}=\"print[^>]*?>[\s\S]*?<\\/div>//gi;t' <<< "<div class=\"print\">
<a href=\"javascript:window.print();\" title=\"Print denne side\"><span class=\"print-btn icon\">P</span> Print denne side</a>
</div>
<div source=\"\">
<div>"