using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div\s\w{5}=\""print[^>]*?>[\s\S]*?<\/div>";
string substitution = @"";
string input = @"<div class=""print"">
<a href=""javascript:window.print();"" title=""Print denne side""><span class=""print-btn icon"">P</span> Print denne side</a>
</div>
<div source="">
<div>";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}