const regex = new RegExp('<div\\s\\w{5}=\\"print[^>]*?>[\\s\\S]*?<\\/div>', 'gi')
const str = `<div class="print">
<a href="javascript:window.print();" title="Print denne side"><span class="print-btn icon">P</span> Print denne side</a>
</div>
<div source="">
<div>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);