use strict;
my $str = '<div class="print">
<a href="javascript:window.print();" title="Print denne side"><span class="print-btn icon">P</span> Print denne side</a>
</div>
<div source="">
<div>';
my $regex = qr/<div\s\w{5}=\"print[^>]*?>[\s\S]*?<\/div>/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";