re = /<div\s\w{5}=\"print[^>]*?>[\s\S]*?<\/div>/i
str = '<div class="print">
<a href="javascript:window.print();" title="Print denne side"><span class="print-btn icon">P</span> Print denne side</a>
</div>
<div source="">
<div>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result