Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?P<dialect>[^+:]+) (?: \+ (?P<driver>[^:]+) )? :// (?P<username>[^:@]+) (?: : (?P<password>[^@]+) )? @ (?P<host>[^:/]+) (?: : (?P<port>\S+) )? / (?P<database>.*)
"
x
Test String
New
dialect+driver://username:password@host:port/database