import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (?P<dialect>[^+:]+)\n"
+ " (?:\n"
+ " \\+\n"
+ " (?P<driver>[^:]+)\n"
+ " )?\n"
+ " ://\n"
+ " (?P<username>[^:@]+)\n"
+ " (?:\n"
+ " :\n"
+ " (?P<password>[^@]+)\n"
+ " )?\n"
+ " @\n"
+ " (?P<host>[^:/]+)\n"
+ " (?:\n"
+ " :\n"
+ " (?P<port>\\S+)\n"
+ " )?\n"
+ " /\n"
+ " (?P<database>.*)\n";
final String string = "dialect+driver://username:password@host:port/database";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}