import Foundation
let pattern = #"""
(?P<dialect>[^+:]+)
(?:
\+
(?P<driver>[^:]+)
)?
://
(?P<username>[^:@]+)
(?:
:
(?P<password>[^@]+)
)?
@
(?P<host>[^:/]+)
(?:
:
(?P<port>\S+)
)?
/
(?P<database>.*)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"dialect+driver://username:password@host:port/database"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}