re = /(on-demand\/[a-z0-9\-]+)
/
str = 'http://video.google.co.uk:80/on-demand/bananas/chantilly'
# Print the match result
str.match(re) do |match|
puts match.to_s
end