#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\d{1,2}+\.\d{1,2}\.\d{1,2}\.\d{1,2}$)"
Local $sString = "qsdf4ghjk dfdf dfd 4fdfd3 d" & @CRLF & _
"4444" & @CRLF & _
"but not 4444" & @CRLF & _
"4444" & @CRLF & _
"333" & @CRLF & _
"44444.4444" & @CRLF & _
"2222" & @CRLF & _
"1" & @CRLF & _
"2." & @CRLF & _
"3" & @CRLF & _
"555" & @CRLF & _
"6.6.7" & @CRLF & _
"44.5." & @CRLF & _
"4.5.6." & @CRLF & _
"4.5.6.7" & @CRLF & _
"44.44.6.4" & @CRLF & _
"12.12.12.12" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"dddd" & @CRLF & _
"this is a test of 3.4 and 3.4.5 and 3.4.5.6 and 33.44.55.66" & @CRLF & _
" hopefully something is learnded. qsdf4ghjk, " & @CRLF & _
"2.4.5.6.7 is here but at the beginning lets's put" & @CRLF & _
"2.3.5.7 but not 2.4.6.7. No space 2.4.6.7 ." & @CRLF & _
" 3.5.6.7. " & @CRLF & _
" 3.3.3" & @CRLF & _
" 44" & @CRLF & _
" 3.3.3.3" & @CRLF & _
" 4.5.6.7.8 and more"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")