# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\d{1,2}+\.\d{1,2}\.\d{1,2}\.\d{1,2}$)"
test_str = ("qsdf4ghjk dfdf dfd 4fdfd3 d\n"
"4444\n"
"but not 4444\n"
"4444\n"
"333\n"
"44444.4444\n"
"2222\n"
"1\n"
"2.\n"
"3\n"
"555\n"
"6.6.7\n"
"44.5.\n"
"4.5.6.\n"
"4.5.6.7\n"
"44.44.6.4\n"
"12.12.12.12\n\n\n"
"dddd\n"
"this is a test of 3.4 and 3.4.5 and 3.4.5.6 and 33.44.55.66\n"
" hopefully something is learnded. qsdf4ghjk, \n"
"2.4.5.6.7 is here but at the beginning lets's put\n"
"2.3.5.7 but not 2.4.6.7. No space 2.4.6.7 .\n"
" 3.5.6.7. \n"
" 3.3.3\n"
" 44\n"
" 3.3.3.3\n"
" 4.5.6.7.8 and more")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.