use strict;
my $str = '/foo/bar/baz/
/foo/bar/
/foo/bar
/foo/';
my $regex = qr/^(?=.*(?:.*?\/){3,})(.*)\/$/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";