import Foundation
let pattern = #"^(?=.*(?:.*?\/){3,})(.*)\/$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/foo/bar/baz/
/foo/bar/
/foo/bar
/foo/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)