Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
\b(\d+)\b
/
Input 1
1
New
"18775551234" "person" <5551234>, "text, might match an email" <foo@bar.com> "SomeText" "18775551234", "SomeText", "foo@bar.com" <foo@bar.com> "foo@bar.com"