$re = '/(?<=\()[^()]{1,10}(?=\))/';
$str = '(some text) some other text -> some text
(some) some other text -> some
(12345) some other text -> 12345
(TooLongStri) -> nothing matched because 11 characters';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);